
ScanFax Help

Panels:
ScanFax screen is separated into two panels or windows - Recipient info panel and Image panel. The 
panels can be resized so one panel can cover the other. There are also two toolbars (a row of buttons), 
each associated with one of the panels. The toolbar on the top controls the Recipient information panel, 
and the toolbar on the right controls the Image panel. The appropriate toolbar is activated by clicking on 
the corresponding panel.

Recipient Information Panel 
The panel on the left (Recipient Information Panel) is for entering the destination information, such as fax 
number, name and company of the recipient. The name and company fields will appear on the destination
fax to provide more information about the recipient. This panel has a built-in address book. The user can 
navigate the entries in the address book by selecting an entry from the NAME combo box, or by the 
toolbar keys [

] on the top of the screen. A new entry is added to the address book by first typing the entry and then 
clicking on the [Add Entry [

]    ] button on the toolbar. An entry may be modified and saved in the address book by clicking on the 
[Save Changes [

] ] button on the toolbar.    To delete an entry from the address book, select the entry and click on the 
[Delete Entry [

] ] button on the toolbar. This panel also has a [SCAN] button to scan the image from the scanner, and a 
[SEND] button to send the image to the destination fax. 

Image Edit Panel
The right panel displays an image which could be scanned with a TWIAN compatible scanner or read 
from a graphics file. The image can be manipulated using the TOOLBAR on the right side of the screen. 
The buttons on this toolbar are self explanatory. You can get some hints by positioning the mouse cursor 
on top of any of the buttons for a few seconds without moving it. A tip will appear, describing the use of 
this button.

Mail Setup:
This screen is activated by clicking on the ‘Setup Mail’    [ ] button on the top toolbar. This screen is used 
to enter mail-related information, such as e-mail address, mail server, ports etc. This info is specific to the 
user. If you have an e-mail program, such as Eudora or MS Exchange you can copy the settings from 
there. This screen also allows you to disable the scanner capabilities, in case you are not using a 
scanner. This will eliminate annoying messages from appearing on your screen. Also, you can change the
prefix and postfix on the TPC-specific address in case it is changed in the future. The prefix and postfix 
refer to the part of the e-mail address before and after the fax number. You should NOT modify this entry 
now.

To get more help on editing and manipulating images, refer to the ‘Image Edit Help’.



 ScanFax! Help Index

How To ...
<<add your application-specific "how to" topics here>>

Commands
File menu
Edit menu
Record menu
View menu
Window menu
Help menu



File menu commands

The File menu offers the following commands:

New Creates a new document.
Open Opens an existing document.
Close Closes an opened document.
Save Saves an opened document using the same file name.
Save As Saves an opened document to a specified file name.
Print Prints a document.
Print 
Preview

Displays the document on the screen as it would appear printed.

Print Setup Selects a printer and printer connection.
Send... Sends the active document through electronic mail.
Exit Exits ScanFax!.



Edit menu commands

The Edit menu offers the following commands:

Undo Reverse previous editing operation.
Cut Deletes data from the document and moves it to the clipboard.
Copy Copies data from the document to the clipboard.
Paste Pastes data from the clipboard into the document.
Paste Link Pastes from the clipboard a link to data in another application.
Insert New 
Object

Inserts and embeds an object, such as a chart or an equation in a document.

Links List and edit links to embedded documents.



View menu commands

The View menu offers the following commands:

Toolbar Shows or hides the toolbar.
Status Bar Shows or hides the status bar.

Window menu commands

The Window menu offers the following commands, which enable you to arrange multiple 
views of multiple documents in the application window:

New Window Creates a new window that views the same document.
Cascade Arranges windows in an overlapped fashion.
Tile Arranges windows in non-overlapped tiles.
Arrange Icons Arranges icons of closed windows.
Split Split the active window into panes.
Window 1, 
2, ...

Goes to specified window.



Help menu commands

The Help menu offers the following commands, which provide you assistance with this 
application: 

Help 
Topics

Offers you an index to topics on which you can get help.

About Displays the version number of this application.



New command (File menu)

Use this command to create a new document in ScanFax!.    Select the type of new file you 
want to create in the File New dialog box.    << Remove previous sentence if your application
supports only one document type. >>

You can open an existing document with the Open command.

Shortcuts

Toolbar:
Keys: CTRL+N



File New dialog box

<< Delete this help topic if your application supports only one document type. >>

Specify the type of document you wish to create:
<< List your application's document types here >>



Open command (File menu)

Use this command to open an existing document in a new window.    You can open multiple 
documents at once.    Use the Window menu to switch among the multiple open documents.  
See Window 1, 2, ... command.

You can create new documents with the New command.

Shortcuts

Toolbar:
Keys: CTRL+O



File Open dialog box

The following options allow you to specify which file to open:
File Name

Type or select the filename you want to open.    This box lists files with the extension you 
select in the List Files of Type box. 

List Files of Type
Select the type of file you want to open:
<< List your application's file types here. >>

Drives
Select the drive in which ScanFax! stores the file that you want to open. 

Directories
Select the directory in which ScanFax! stores the file that you want to open.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 



Close command (File menu)

Use this command to close all windows containing the active document.    ScanFax! suggests
that you save changes to your document before you close it.    If you close a document 
without saving, you lose all changes made since the last time you saved it.    Before closing 
an untitled document, ScanFax! displays the Save As dialog box and suggests that you name
and save the document.

You can also close a document by using the Close icon on the document's window, as shown 
below:



Save command (File menu)

Use this command to save the active document to its current name and directory.    When 
you save a document for the first time, ScanFax! displays the Save As dialog box so you can 
name your document.    If you want to change the name and directory of an existing 
document before you save it, choose the Save As command.

Shortcuts

Toolbar:
Keys: CTRL+S



Save As command (File menu)

Use this command to save and name the active document.    ScanFax! displays the Save As 
dialog box so you can name your document.    

To save a document with its existing name and directory, use the Save command.



Send command (File menu)

Use this command to send the active document through electronic mail.    This command 
presents a mail window with the active document attached to it.    You may then fill out the 
To: field, Subject: field, etc., and add text to the body of the message if you wish.    When you
are finished you may click the "Send" button to send the message.



File Save As dialog box

The following options allow you to specify the name and location of the file you're about to 
save:
File Name

Type a new filename to save a document with a different name.    A filename can contain 
up to eight characters and an extension of up to three characters.    ScanFax! adds the 
extension you specify in the Save File As Type box.

Drives
Select the drive in which you want to store the document.

Directories
Select the directory in which you want to store the document.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 

<< Add other File Save As dialog box options depending on which ones your application 
chooses via the OFN_ flags of the OPENFILENAME structure used by the CFileDialog. >>



1, 2, 3, 4 command (File menu)

Use the numbers and filenames listed at the bottom of the File menu to open the last four 
documents you closed.    Choose the number that corresponds with the document you want 
to open.



Exit command (File menu)

Use this command to end your ScanFax! session.    You can also use the Close command on 
the application Control menu.    ScanFax! prompts you to save documents with unsaved 
changes.

Shortcuts
Mouse: Double-click the application's Control menu button.

Keys: ALT+F4



Undo/Can't Undo command (Edit menu)

<< Your application's user interface for Undo may differ from the one described below.    
Modify this help text accordingly. >>

Use this command to reverse the last editing action, if possible.      The name of the 
command changes, depending on what the last action was.    The Undo command changes to
Can't Undo on the menu if you cannot reverse your last action.

Shortcuts

Toolbar:
Keys: CTRL+Z or

ALT-BACKSPACE



Redo command (Edit menu)

<< Write application-specific help here. >>



Cut command (Edit menu)

Use this command to remove the currently selected data from the document and put it on 
the clipboard.    This command is unavailable if there is no data currently selected.

Cutting data to the clipboard replaces the contents previously stored there.

Shortcuts

Toolbar:
Keys: CTRL+X



Copy command (Edit menu)

Use this command to copy selected data onto the clipboard.    This command is unavailable if
there is no data currently selected.

Copying data to the clipboard replaces the contents previously stored there.

Shortcuts

Toolbar:
Keys: CTRL+C



Paste command (Edit menu)

Use this command to insert a copy of the clipboard contents at the insertion point.    This 
command is unavailable if the clipboard is empty.

Shortcuts

Toolbar:
Keys: CTRL+V



Toolbar command (View menu)

Use this command to display and hide the Toolbar, which includes buttons for some of the 
most common commands in ScanFax!, such as File Open.    A check mark appears next to the
menu item when the Toolbar is displayed.

See Toolbar for help on using the toolbar.



Toolbar

The toolbar is displayed across the top of the application window, below the menu bar.    The 
toolbar provides quick mouse access to many tools used in ScanFax!,

To hide or display the Toolbar, choose Toolbar from the View menu (ALT, V, T).

<< Add or remove toolbar buttons from the list below according to which ones your 
application offers. >>

Click To

Open a new document.

Open an existing document.    ScanFax! displays the Open dialog box, in which you 
can locate and open the desired file.

Save the active document or template with its current name.    If you have not named
the document, ScanFax! displays the Save As dialog box.

Print the active document.

Remove selected data from the document and stores it on the clipboard.

Copy the selection to the clipboard.

Insert the contents of the clipboard at the insertion point.

Reverse the last editing.    Note:    You cannot undo some actions.

Go to the first record in the current selection.

Go to the previous record in the current selection.

Go to the next record in the current selection.

Go to the last record in the current selection.



Status Bar command (View menu)

Use this command to display and hide the Status Bar, which describes the action to be 
executed by the selected menu item or depressed toolbar button, and keyboard latch state. 
A check mark appears next to the menu item when the Status Bar is displayed.

See Status Bar for help on using the status bar.



Status Bar

The status bar is displayed at the bottom of the ScanFax! window.    To display or hide the 
status bar, use the Status Bar command in the View menu.

The left area of the status bar describes actions of menu items as you use the arrow keys to 
navigate through menus.    This area similarly shows messages that describe the actions of 
toolbar buttons as you depress them, before releasing them.    If after viewing the description
of the toolbar button command you wish not to execute the command, then release the 
mouse button while the pointer is off the toolbar button.

The right areas of the status bar indicate which of the following keys are latched down:

Indicator Description
CAP The Caps Lock key is latched down.
NUM The Num Lock key is latched down.
SCRL The Scroll Lock key is latched down.



New command (Window menu)

Use this command to open a new window with the same contents as the active window.    You
can open multiple document windows to display different parts or views of a document at 
the same time.    If you change the contents in one window, all other windows containing the 
same document reflect those changes.    When you open a new window, it becomes the 
active window and is displayed on top of all other open windows.



Cascade command (Window menu)

Use this command to arrange multiple opened windows in an overlapped fashion. 



Tile command (Window menu)

Use this command to arrange multiple opened windows in a non-overlapped fashion.



Tile Horizontal command (Window menu)

Use this command to vertically arrange multiple opened windows in a non-overlapped 
fashion.



Tile Vertical command (Window menu)

Use this command to arrange multiple opened windows side by side.



Window Arrange Icons Command

Use this command to arrange the icons for minimized windows at the bottom of the main 
window.    If there is an open document window at the bottom of the main window, then 
some or all of the icons may not be visible because they will be underneath this document 
window.



Split Command (Window menu)

Use this command to split the active window into panes.    You may then use the mouse or 
the keyboard arrows to move the splitter bars.    When you are finished, press the mouse 
button or enter to leave the splitter bars in their new location.    Pressing escape keeps the 
splitter bars in their original location.    << In a single document interface application, this 
command will appear on the View menu. >>



1, 2, ... command (Window menu)

ScanFax! displays a list of currently open document windows at the bottom of the Window 
menu.    A check mark appears in front of the document name of the active window.    Choose
a document from this list to make its window active.    



Index command (Help menu)

Use this command to display the opening screen of Help.    From the opening screen, you can
jump to step-by-step instructions for using ScanFax! and various types of reference 
information.    

Once you open Help, you can click the Contents button whenever you want to return to the 
opening screen.



Using Help command (Help menu)

Use this command for instructions about using Help.



About command (Help menu)

Use this command to display the copyright notice and version number of your copy of 
ScanFax!.



Context Help command 

Use the Context Help command to obtain help on some portion of ScanFax!.    When you 
choose the Toolbar's Context Help button, the mouse pointer will change to an arrow and 
question mark.    Then click somewhere in the ScanFax! window, such as another Toolbar 
button.    The Help topic will be shown for the item you clicked.

Shortcut
Keys: SHIFT+F1



Title Bar

<< Show your application's title bar here. >>

The title bar is located along the top of a window.    It contains the name of the application 
and document.

To move the window, drag the title bar.    Note: You can also move dialog boxes by dragging 
their title bars.

A title bar may contain the following elements:
Application Control-menu button
Document Control-menu button
Maximize button
Minimize button
Name of the application
Name of the document
Restore button



Scroll bars

Displayed at the right and bottom edges of the document window.    The scroll boxes inside 
the scroll bars indicate your vertical and horizontal location in the document.    You can use 
the mouse to scroll to other parts of the document.

<< Describe the actions of the various parts of the scrollbar, according to how they behave 
in your application. >>



Size command (System menu)

Use this command to display a four-headed arrow so you can size the active window with the
arrow keys.

After the pointer changes to the four-headed arrow:
1. Press one of the DIRECTION keys (left, right, up, or down arrow key) to move the pointer 

to the border you want to move.    
2. Press a DIRECTION key to move the border.
3. Press ENTER when the window is the size you want.

Note:    This command is unavailable if you maximize the window.

Shortcut
Mouse: Drag the size bars at the corners or edges of the window.



Move command (Control menu)

Use this command to display a four-headed arrow so you can move the active window or 
dialog box with the arrow keys.

Note:    This command is unavailable if you maximize the window.

Shortcut
Keys: CTRL+F7



Minimize command (application Control menu)

Use this command to reduce the ScanFax! window to an icon.

Shortcut

Mouse: Click the minimize icon  on the title bar.
Keys: ALT+F9



Maximize command (System menu)

Use this command to enlarge the active window to fill the available space.

Shortcut

Mouse: Click the maximize icon  on the title bar; or double-click the title bar.
Keys: CTRL+F10 enlarges a document window.



Next Window command (document Control menu)

Use this command to switch to the next open document window.    ScanFax! determines 
which window is next according to the order in which you opened the windows.

Shortcut
Keys: CTRL+F6



Previous Window command (document Control menu)

Use this command to switch to the previous open document window.    ScanFax! determines 
which window is previous according to the order in which you opened the windows.

Shortcut
Keys: SHIFT+CTRL+F6



Close command (Control menus)

Use this command to close the active window or dialog box.

Double-clicking a Control-menu box is the same as choosing the Close command.

Note:    If you have multiple windows open for a single document, the Close command on the
document Control menu closes only one window at a time.    You can close all windows at 
once with the Close command on the File menu.

Shortcuts
Keys: CTRL+F4 closes a document window

ALT+F4 closes the <<YourType>> window or dialog box



Restore command (Control menu)

Use this command to return the active window to its size and position before you chose the 
Maximize or Minimize command.



Switch to command (application Control menu)

Use this command to display a list of all open applications.    Use this "Task List" to switch to 
or close an application on the list.

Shortcut
Keys: CTRL+ESC

Dialog Box Options
When you choose the Switch To command, you will be presented with a dialog box with the 
following options:
Task List

Select the application you want to switch to or close.
Switch To

Makes the selected application active.
End Task

Closes the selected application.
Cancel

Closes the Task List box.
Cascade

Arranges open applications so they overlap and you can see each title bar.    This option 
does not affect applications reduced to icons.

Tile
Arranges open applications into windows that do not overlap.    This option does not 
affect applications reduced to icons.

Arrange Icons
Arranges the icons of all minimized applications across the bottom of the screen.



Ruler command (View menu)

<< Write application-specific help here. >>



Choose Font dialog box

<< Write application-specific help here. >>



Choose Color dialog box

<< Write application-specific help here. >>



Find command (Edit menu)

<< Write application-specific help here. >>



Find dialog box

<< Write application-specific help here. >>



Replace command (Edit menu)

<< Write application-specific help here. >>



Replace dialog box

<< Write application-specific help here. >>



Repeat command (Edit menu)

Use this command to repeat the last editing command carried out.    The Repeat menu item 
changes to Can't Repeat if you cannot repeat your last action.

Shortcut
Key: F4



Clear command (Edit menu)

<< Write application-specific help here. >>



Clear All command (Edit menu)

<< Write application-specific help here. >>



Next Pane

<< Write application-specific help here. >>



Prev Pane

<< Write application-specific help here. >>



Modifying the Document

<< Write application-specific help here that provides an overview of how the user should 
modify a document using your application.    

If your application supports multiple document types and you want to have a distinct help 
topic for each, then use the help context i.d. generated by running the MAKEHELP.BAT file 
produced by AppWizard.    Alternatively, run MAKEHM as follows:

makehm IDR_HIDR_,0x2000 resource.h

If the IDR_ symbol for one of your document types is, for example, IDR_CHARTTYPE, then the
help context i.d. generated by MAKEHM will be HIDR_CHARTTYPE.

Note, AppWizard defines the HIDR_DOC1TYPE help context i.d. used by this help topic for the
first document type supported by your application.    AppWizard produces an alias in the .HPJ 
file for your application, mapping HIDR_DOC1TYPE to the HIDR_ produced by MAKEHM for 
that document type. >>





No Help Available

No help is available for this area of the window.



No Help Available

No help is available for this message box.

<< If you wish to author help specific to each message box prompt, then remove the 
AFX_HIDP_xxx values from the [ALIAS] section of your .HPJ file, and author a topic for each 
AFX_HIDP_xxx value.    For example, AFX_HIDP_INVALID_FILENAME is the help topic for the 
Invalid Filename message box. >>





Print command (File menu)

Use this command to print a document.      This command presents a Print dialog box, where 
you may specify the range of pages to be printed, the number of copies, the destination 
printer, and other printer setup options.

Shortcuts

Toolbar:
Keys: CTRL+P



Print dialog box

The following options allow you to specify how the document should be printed:
Printer

This is the active printer and printer connection.    Choose the Setup option to change the
printer and printer connection.

Setup
Displays a Print Setup dialog box, so    you can select a printer and printer connection.

Print Range
Specify the pages you want to print:
All Prints the entire document.
Selectio
n

Prints the currently selected text.

Pages Prints the range of pages you specify in the From and To boxes.
Copies

Specify the number of copies you want to print for the above page range.
Collate Copies

Prints copies in page number order, instead of separated multiple copies of each page.
Print Quality

Select the quality of the printing.    Generally, lower quality printing takes less time to 
produce.



Print Progress Dialog

The Printing dialog box is shown during the time that <<YourApp>> is sending output to the
printer.    The page number indicates the progress of the printing.

To abort printing, choose Cancel.



Print Preview command (File menu)

Use this command to display the active document as it would appear when printed.    When 
you choose this command, the main window will be replaced with a print preview window in 
which one or two pages will be displayed in their printed format.    The print preview toolbar 
offers you options to view either one or two pages at a time; move back and forth through 
the document; zoom in and out of pages; and initiate a print job.



Print Preview toolbar

The print preview toolbar offers you the following options:
Print

Bring up the print dialog box, to start a print job.
Next Page

Preview the next printed page.
Prev Page

Preview the previous printed page.
One Page / Two Page

Preview one or two printed pages at a time.
Zoom In

Take a closer look at the printed page.
Zoom Out

Take a larger look at the printed page.
Close

Return from print preview to the editing window.



Print Setup command (File menu)

Use this command to select a printer and a printer connection.    This command presents a 
Print Setup dialog box, where you specify the printer and its connection.



Print Setup dialog box

The following options allow you to select the destination printer and its connection.
Printer

Select the printer you want to use.    Choose the Default Printer; or choose the Specific 
Printer option and select one of the current installed printers shown in the box.    You 
install printers and configure ports using the Windows Control Panel. 

Orientation
Choose Portrait or Landscape.

Paper Size
Select the size of paper that the document is to be printed on.

Paper Source
Some printers offer multiple trays for different paper sources.    Specify the tray here.

Options
Displays a dialog box where you can make additional choices about printing, specific to 
the type of printer you have selected.

Network...
Choose this button to connect to a network location, assigning it a new drive letter.



Page Setup command (File menu)

<< Write application-specific help here. >>




